Username: Password:

Author Topic: Pick up warranty and low volume problem  (Read 133 times)

realguitarshredder

  • Junior Flyweight
  • *
  • Posts: 22
Pick up warranty and low volume problem
« on: June 06, 2021, 04:08:18 PM »
Hi Guys, I had joined this forum back in 2006 when this was still new and just bought a nailbomb bridhe pickup (the first ones that came out)  from Newcastle UK. I think it was guitar centre or something like that. When I bought it I did see there was a warranty card there. But since I wanted to fit it right away I just gave it to the shop. The next day I got the guitar but they said they threw the box away along with the warranty card. But the owner of that place said "its got lifetime warranty and if you talk to Tim he will sort it out." Didn't know who Tim was at that time. So I thought alright the pickup must have some serial number inside and when they will look at it they will see its bareknuckles and so I don't really need to put any dates in it.  But now that I have read some stuff that you need to register it for lifetime warranty and you needed to register it then. So.. Do I get a lifetime warranty with this? Its working absolutely perfect since 2006 and all my video from www.youtube.com/realguitarshredder are all that pickup since 2007.

The problem: Now that i am back in India and err the place where am at is not really known to have guitar techs around. I gave the guitar to fix a switch and well he did but there was a problem with low output of the bridge pickup but only with the 1st string, the rest sounded fine. Couldn't solve it. And right now as I am trying to record something with the guitar directly connected to the audio interface (no amps) I have noticed that now the overall volume of the bridge pickup is less than the stock ones. I only noticed it while playing it clean so took me sometime to find it out. Is this a pickup problem or a connection problem? Also the fact that the volume is less in the first string errr.. is that normal too? I just havent noticed that in the beginning so i am just trying to see if there is something wrong with my memory or something wrong with the pickup.. I have attached a soundclip. its a 5 way switch, from the bridge to the neck.

sigh yeah I know, long post. Thanks in advance for the replies.
« Last Edit: June 06, 2021, 04:38:50 PM by realguitarshredder »
guitars keep me alive while studies put me to sleep ;)

b.gandt

  • Junior Flyweight
  • *
  • Posts: 46
Re: Pick up warranty and low volume problem
« Reply #1 on: June 11, 2021, 05:53:37 PM »
Is it possible for one end of a bar magnet do demagnetize?   I don't know enough to say one way or another.

I mention that because I had a bar nag in a P90 have the same volume loss over the B and e strings.  The winder, a small volume guy here in the States just sent another one right away, and didn't really say much other than "Another one is on the way".

I know even less about the rest of your pickup issues!  Best wishes with them.