Username: Password:

Author Topic: Power tubes going bad?  (Read 1546 times)

_tom_

  • Middleweight
  • *****
  • Posts: 8842
Power tubes going bad?
« on: June 29, 2010, 03:37:00 PM »
Amp is a Laney GH50L. This problem has been happening for a while - occasionally the sound will lose a load of power and clarity, goes quite mushy and lacks punch. Then it'll "kick in" again with the proper sound which is bigger/punchier and a lot more trebbly.

A few months ago I got some new preamp tubes and thought these solved the problem. However I forgot to order 4 so one of them is still the original one. I think V3 is still the original, the rest are JJ 12AX7s (which seem to sound no different to the stock TADs, btw :lol: )

The power amps are Svetlana Winged C EL34s, I got them a few years ago I think but I don't think they've been used excessively since I only gig about once every few months and have done since getting them fitted. I did notice that when the amp came back from fitting/biasing they seemed a lot hotter than the old tubes (to the point of the grille being hot enough to be painful to touch for a few seconds), so maybe they were biased too hot and therefore worn out quicker?

So does this sound like a power amp valve problem and if so what should I replace them with? They do still sound great when they're working so I'm thinking more of the same!

Denim n Leather

  • Guest
Re: Power tubes going bad?
« Reply #1 on: June 29, 2010, 07:42:02 PM »
Yep, get another set of the same. Your amp will sound like new!

hunter

  • Middleweight
  • *****
  • Posts: 5262
    • http://www.myspace.com/christophjaeger
Re: Power tubes going bad?
« Reply #2 on: June 29, 2010, 10:16:58 PM »
Could be a preamp tube as well.

First I'd mix and replace the pres and see if it comes back.
Tweaker's Paradise - Player's nightmare.

_tom_

  • Middleweight
  • *****
  • Posts: 8842
Re: Power tubes going bad?
« Reply #3 on: June 30, 2010, 04:39:40 PM »
It actually seems like its not tube related - just had a play around with the FX Return Level pot as I just remembered this has always been a bit dodgy. I think it's the problem as even the slightest touch will make the sound go dull and weak - cranking it to 10 and wiggling it til it sounds bright and punchy is a huge difference! So I guess the pot needs to be replaced :(

Denim n Leather

  • Guest
Re: Power tubes going bad?
« Reply #4 on: June 30, 2010, 04:42:13 PM »
Well, better that you know instead of throwing good money after bad!

Dmoney

  • Welterweight
  • ****
  • Posts: 3577
Re: Power tubes going bad?
« Reply #5 on: June 30, 2010, 04:49:43 PM »
It actually seems like its not tube related - just had a play around with the FX Return Level pot as I just remembered this has always been a bit dodgy. I think it's the problem as even the slightest touch will make the sound go dull and weak - cranking it to 10 and wiggling it til it sounds bright and punchy is a huge difference! So I guess the pot needs to be replaced :(

you could try cleaning it with a spray?