Username: Password:

Author Topic: MXR Phase 90 Problem  (Read 1745 times)

Bird

  • Lightweight
  • ***
  • Posts: 949
MXR Phase 90 Problem
« on: October 08, 2007, 08:20:52 PM »
It was working fine but not any more. The light stays on when the pedal is not engaged. It's dimmer than when the pedal is on. It's also sucking tone like crazy now. The gain seems to be cut in half when the pedal is plugged in and it's very middy/flat sounding. Any ideas  :?:
"Jazz isn't dead, it just smells funny." Frank Zappa

Oli

  • Lightweight
  • ***
  • Posts: 914
MXR Phase 90 Problem
« Reply #1 on: October 08, 2007, 08:29:16 PM »
The switch might have gone component-heaven :(
Sounds like it's partially making contact when it shouldn't be (hence the dimmer light, and nasty tone)- probably from normal wear and tear. That said, i've not used that unit before, so it could be something else; that's my best guess though. I'd imagine that the switch is a fairly standard one, won't cost too much to replace, and if you're a dab hand with a soldering iron you'll have no issues :)
Nailbomb, VHII, Warpig 7, MQ, Black Dog, 10th Anniversary

Bird

  • Lightweight
  • ***
  • Posts: 949
MXR Phase 90 Problem
« Reply #2 on: October 08, 2007, 09:13:10 PM »
Damn pedals. I'll have to see if I can find a suitable switch. No, obvious problems when I looked inside the pedal. I'll try replacing the switch and see what happens. Thanks  :)
"Jazz isn't dead, it just smells funny." Frank Zappa

Oli

  • Lightweight
  • ***
  • Posts: 914
MXR Phase 90 Problem
« Reply #3 on: October 08, 2007, 10:11:01 PM »
Does the 'action' of the switch feel loose? I mean, if the switch itself not feel heavy duty anymore, that'd be another sign that the switch may be the culprit.
Nailbomb, VHII, Warpig 7, MQ, Black Dog, 10th Anniversary